Авторизация

Логин или эл. почта: Регистрация
Пароль: Напомнить пароль



Статьи В x64 версии Ubuntu не кликаются Flashприложения — что делать? #

После переезда с 32-битной версии Ubuntu на 64-битную, я заметил, что стандартный («поддерживаемый») Flash-проигрыватель перестал воспринимать клики. То есть, стало невозможно, например, перемотать видео в YouTube и так далее. Что ж, давайте разберемся с этим…-Как выяснилось, Adobe до сих пор не выпустил стабильную версию Flash-проигрывателя под 64-битный Linux. Поэтому в Can onical приняли решение использовать 32-битную версию через обертку nspluginwrapper. Да-да, именно поэтому при установке Flash-проигрыватель тянет с собой около 40 мегабайт библиотек…-Если вы предпочитаете поддерживаемое программное обеспечение, тогда данная версия устанавливается очень просто:
sudo apt-get install flashplugin-installerНо, именно с ней есть описанная выше проблема с невосприимчивостью к кликам. Впрочем, решается она достаточно просто — нужно лишь добавить строчку: export GDK_NATIVE_WINDOWS=1 в файл /usr/lib/nspluginwrapper/i386/linux/npviewer, прямо перед последней строкой. Должно получиться что-то типа такого:#!/bin/sh
TARGET_OS=linux
TARGET_ARCH=i386
export GDK_NATIVE_WINDOWS=1
. /usr/lib/nspluginwrapper/noarch/npviewerПосле этого перезапускаем броузер, и всё работает как надо, но…- сильно жрёт процессор. Очень сильно жрёт процессор…-Особо пытливые люди заметили, что Adobe с упорством бульдозера разрабатывает-таки 64-битную версию Flash-проигрывателя. Она помечена как «prerelease», но её уже можно скачать и установить.Действия нужно совершить примерно следующие:удалить все возможные установленные версии Flash-проигрывателя-скачать архив с сайта Adobe, разархивировать-взять файл libflashplayer.so и поместить его в папку ~/.mozilla/plugins/, или в /usr/lib/mozilla/plugins/.По идее, после этого всё должно работать хорошо, красиво и правильно. Но иногда бывают сбои, не знаю, с чем это связано. Я ставил таким образом Flash-проигрыватель несколько раз, и результат был непредсказуемо разным: то плагин не определялся вообще, то продолжал быть «некликабельным», то тормозил сильнее, чем 32-битная версия. Нужно пробовать, заранее не угадаешь…-В документации к Ubuntu есть ещё одна вариация, как поставить Flash-проигрыватель на 64-битную систему. Он сложный, хотя, подозреваю, в отличие от моего второго варианта (прямая запись плагина в папку), обладает возможностью автоматического обновления. Расскажу вкратце, если кому-то нужны более подробные инструкции, перейдите по ссылке выше, там всё очень подробно.Удалить все возможные установленные версии Flash-проигрывателя-скачать свежую «prerelease» версию 64-битного Flash-проигрывателя с сайта Adobe Labs-переместить файл из архива в папку /usr/lib/flashplugin-installer/ (возможно, папку нужно предварительно создать)-установить ссылку на библиотеку в качестве альтернативной версии плагина-обновить альтернативы и перезапустить Firefox.Выглядит страшно и непонятно, но на деле, всё просто и сводится к нескольким командам. Опять же, подробности в мануале. Я не расписываю этот способ подробно, потому что результат примерно такой же непредсказуемый, как и при прямой записи плагина в папку.В заключение хочу сказать, что Adobe — свиньи, потому что до сих пор не могут зарелизить 64-битный Flash-проигрыватель, а нам, владельцам 64-битных систем, остается только ждать и мучиться с 32-битной версией и тормозами…-
  • +1
  • admin
  • 17 ноября 2008, 07:41

Комментарии 0

свернуть / развернуть
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.

Блоги, Статьи, В x64 версии Ubuntu не кликаются Flashприложения — что делать?